FPse crashes no matter what the settings

PittedPonay
Fresh Fish
Posts: 2
Joined: Thu Apr 03, 2014 6:57 pm
Primary Device: ZTE Score; ARMv6; Adreno 200.
Operating System: Android Gingerbread
ROM: Stock, MetroPCS

FPse crashes no matter what the settings

Postby PittedPonay » Thu Apr 03, 2014 7:04 pm

I have an unrooted Gingerbread Android OS (everything supplied OEM, no ROM flashing). The gameplay is fine enough, but no matter what PS1 game played, the program will always crash in some random range of time between 0 seconds and 1 hour every single time, no matter what. I have counted and tested and it does this, seemingly almost like it's on purpose.

While playing Final Fantasy VIII I have to save after every battle or so to make sure I don't lose progress, and it's a real PITA.

Aside from that I have been playing and enjoying the emulator well, but the problem is the damn crashing. Most of the time it just crashes, there's no log messages I can find from the app, and there's no error messages either. Sometimes it says there's not enough RAM but there always is plenty and then some available.

My question is, why is this happening? Why can't the app continue running a game ROM without crashing exactly between 0 seconds and 1 hour? Sometimes I lose parts of the game because I forget to save every other few minutes. It's annoying and ruins the gameplay experience having to struggle and hope there's not another random crash 1 minute in.

I have cleared all app settings, re-installed, tried different versions, cleared Dalvik cache, rebooted, freed up plenty of RAM, killed background apps and give the app full resource hogging as much as possible. Nothing changes. What is wrong with the app? Or is it Android killing it for some reason?

What suggestions can you give me?

User avatar
schtruck
Site Admin
Posts: 2123
Joined: Tue Jan 13, 2009 8:52 am
Primary Device: HTC HD2
Operating System: WM 6.5.1 21869
ROM: 1.66
Location: PARIS
Contact:

Re: FPse crashes no matter what the settings

Postby schtruck » Thu Apr 10, 2014 2:41 am

you update to last version, it should be better now, i fixed a random crash problem when FPS was on.

PittedPonay
Fresh Fish
Posts: 2
Joined: Thu Apr 03, 2014 6:57 pm
Primary Device: ZTE Score; ARMv6; Adreno 200.
Operating System: Android Gingerbread
ROM: Stock, MetroPCS

Re: FPse crashes no matter what the settings

Postby PittedPonay » Mon Apr 28, 2014 6:55 pm

It crashes even with FPS off, and under any combination of settings. The crash problem varies, but I guess I'll just eventually try out the newer version as you suggest. I'm just letting you know of this issue with random crashing for no reason; it is time consuming. The emulator's great in every other respect (except for sound emulation), so I'm not complaining.

I know how hard it is to make emulators.

User avatar
bluezeak
Guru
Posts: 600
Joined: Fri Feb 03, 2012 10:04 am
Primary Device: motorola bionic
Operating System: Android 2.3.4
ROM: stock

Re: FPse crashes no matter what the settings

Postby bluezeak » Mon Apr 28, 2014 7:46 pm

Schtruck has released several updates since April 3. Try using the latest one.
FPSE OpenGL info - click here


Return to “General Discussion”

Who is online

Users browsing this forum: No registered users and 10 guests