SaGa Frontier 2

If you have a problem with a particular game, post it in here.
Fresh Fish
Posts: 1
Joined: Sun Nov 04, 2012 7:52 pm
Primary Device: Xperia Arc S
Operating System: Android
ROM: Final Fantasy VIII

SaGa Frontier 2

Postby Mishi » Sun Nov 04, 2012 7:59 pm

I'm having some issues when starting SaGa Frontier 2 in FPse on my Xperia :/
I'm using the NTSC-U version and whenever I start the game the battle theme just starts playing along with some random sound effects and I get a black screen instead of the title screen.
Is this game compatible with FPse or is it i've got a corrupt game file? I mean I've tried a bunch and every single one has the same problem...

Fresh Fish
Posts: 1
Joined: Sun Jun 16, 2013 4:01 pm
Primary Device: SII

Re: SaGa Frontier 2

Postby vimes81 » Sun Jun 16, 2013 4:17 pm

I've also had problems with Saga Frontier 2 and FPse
I got some scene where two groups fight, then scene when boy is born (king goes to a castle and names his heir) and then game went blank.
The problem turns out was caused by incorrect game file as in ePSXe I got the same problem.
After finding correct game file its working fine on FPse.

Junior Member
Posts: 17
Joined: Wed May 09, 2012 1:17 am
Primary Device: Xperia Play

Re: SaGa Frontier 2

Postby helloworld » Sun Jun 23, 2013 12:52 am

i tried my copy and it worked fine. i got past the first scene and played the game normally.

your copy is probably corrupted.

Return to “Game-Specific Help”

Who is online

Users browsing this forum: No registered users and 5 guests