Phonejoy native support screwy mapping and missing keys

smash
Junior Member
Posts: 11
Joined: Fri Jul 13, 2012 12:37 pm
Primary Device: Galaxy Note
Operating System: Android 4.0.3
ROM: Stock

Phonejoy native support screwy mapping and missing keys

Postby smash » Fri Jul 13, 2012 12:54 pm

Hi All

Firstly, from what i can tell so far FPSE is amazing - just how I remember wasting soooo many hours to the PSX - great job.

OK I really want to get the full experience via phonejoy but am having problems...

I have up to date Bluez IME and FPSE running on Galaxy Note with stock Samsung ICS 4.0.3 and am getting strange behaviour when I try to use the phonejoy in native mode on FPSE.

I turn on bluetooth and pair with Phonejoy and then run FPSE and this is the behaviour I get:

1 is mapped to X (instead of Triangle)
3 is mapped to Triangle (instead of X)
4 is mapped to Circle (instead of Square)
2 is mapped to Square (instead of Circle)

Both analog sticks behave as 8 way digital pads

L1, L2, R1, R2, Select and start are all non functional.

Would appreciate any ideas - you don't know how frustrating it is to be able to see Medievil and not be able to play!!!

PS I have reinstalled both BluezIME and FPSE - are any configs left behind upon deletion?

User avatar
bluezeak
Guru
Posts: 709
Joined: Fri Feb 03, 2012 10:04 am
Primary Device: motorola bionic
Operating System: Android 2.3.4
ROM: stock

Re: Phonejoy native support screwy mapping and missing keys

Postby bluezeak » Fri Jul 13, 2012 11:07 pm

Smash said he got this working in a different thread. Smash, let us know if this is still a problem for you.

www.fpsece.net/forum2/viewtopic.php?f=39&t=2681
FPSE OpenGL info - click here

smash
Junior Member
Posts: 11
Joined: Fri Jul 13, 2012 12:37 pm
Primary Device: Galaxy Note
Operating System: Android 4.0.3
ROM: Stock

Re: Phonejoy native support screwy mapping and missing keys

Postby smash » Sat Jul 14, 2012 10:57 am

Yeah that was me! I have a set procedure that works now:

1. Turn on Blue Tooth

2. Switch on phoney-joy and pair

3. Start FPSE (note that it doesn't give any message about connecting with phoney-joy on start up)

4. Quit FPSE (restart does not work for some reason)

5. Start FPSE again and press analog on phoney-joy this time you should see message saying "connected to phonejoy"

*EDITED TO ADD* Make sure FPSE gamepad type is set to analog.

6. Enjoy proper button mapping and true(ish) analog sticks!

JohnW
Junior Member
Posts: 20
Joined: Thu Jul 05, 2012 9:50 am
Primary Device: Asus Transformer T300

Re: Phonejoy native support screwy mapping and missing keys

Postby JohnW » Mon Jul 16, 2012 12:46 pm

I can confirm that this does not always work. Not sure if there is a way to clear any key mapping settings one has done before or it is something else. I am not using OpenGL (messes up textures in way too many games).

smash
Junior Member
Posts: 11
Joined: Fri Jul 13, 2012 12:37 pm
Primary Device: Galaxy Note
Operating System: Android 4.0.3
ROM: Stock

Re: Phonejoy native support screwy mapping and missing keys

Postby smash » Mon Jul 16, 2012 1:46 pm

Make sure you reset FPSE to defaults and don't do anything with the joypad settings apart from to select analog in joypad type - do nothing with bluetooth settings.

JohnW
Junior Member
Posts: 20
Joined: Thu Jul 05, 2012 9:50 am
Primary Device: Asus Transformer T300

Re: Phonejoy native support screwy mapping and missing keys

Postby JohnW » Mon Jul 16, 2012 6:49 pm

Okay here is what I did

Reset the settings to default

Under Joypad Type selected Analog

exited program

Turned on Bluetooth and paired up Phonejoy

Started FPse and noted it did not give me a message about connecting with Phonejoy

Quit FPse

Started up FPse with analog button 'on'

Did NOT see the message about connecting with Phonejoy

No buttons or sticks work

Repeated above with the Gamepad Bluetooth Padport 1 option set to Bgp100 instead of Disabled

Upon reloading FPse the second time I did get the message about connecting with Phonejoy

No buttons or sticks work

On my Asus tablet I can pull up a notification screen and it shows Bluez-IME connected even though I never ran it manually and never turned on bluetooth from with it.

The version of Bluez-IME I am running is 1.17

Bluez-IME seems to have a habit of loading itself whenever the Bluetooth on the tablet is turned on. I have tried two task killers and they both show no Bluez-IME running after I tell it to kill the task until I re-run the task killers and it shows up again. There just doesn't seem to be anyway to keep it from running.


Return to “General Discussion”

Who is online

Users browsing this forum: No registered users and 1 guest