Vagrant Story Corrupted Saves

User avatar
Assasin
Member
Posts: 91
Joined: Sat Jan 02, 2010 6:46 pm
Primary Device: Sony Ericsson Xperia x1
Operating System: 6.1
ROM: stock

Vagrant Story Corrupted Saves

Postby Assasin » Sat Jan 02, 2010 8:20 pm

Hello!
I tried every possible ways to save my progress of Vagrant Story. I do it exacly as it was on a PSX. (Walking on the blue magic field, typing data/save/memory slot 1/New Save).
I use FPSeCE v0.10. I don't want to use your save state because the normal save is fine to me and i can't donate because i don't have paypal, account in bank.
But when i try to save game progress it tells me that there was an error and my saves are corrupted.
What should i do? I downloaded FPSeCE v0.10 -> installed it -> launched it -> launched Vagrant Story -> configured my keyboard -> went through the story of the game -> tried to save.
I read somewhere that in free version of FPSeCE there is a normal save, so wtf? why it doesn't working to me O.o?

Sorry for my English.
With regards.
Image
By Shood

User avatar
alkarl
Member
Posts: 85
Joined: Thu Nov 26, 2009 7:22 am

Re: Vagrant Story Corrupted Saves

Postby alkarl » Sat Jan 02, 2010 9:15 pm

try a different bios, try different memory card format(mcd, gme, etc), try disabling any kind of speed hack, try a pal version.
i am actually interested in the settings you are using because i didn't manage to get past the intro due to crash.
IPAQ 210

Screen: 640x480 VGA 4 inch
Keyboard: d-pad, 6 keys
Memory: 128MB Ram, 256MB Rom
CPU: Marvell PXA310 625Mhz

User avatar
Assasin
Member
Posts: 91
Joined: Sat Jan 02, 2010 6:46 pm
Primary Device: Sony Ericsson Xperia x1
Operating System: 6.1
ROM: stock

Re: Vagrant Story Corrupted Saves

Postby Assasin » Sat Jan 02, 2010 9:40 pm

Hey!
I have downloaded FPSeCE v0.10 from homepage and set my keys.
I use SE Xperia x1 with original WM 6.1.
Vagrant Story is working 20-30 FPS.
There is some king of a slowmotion, so i use frameskip 3.
I am newbie, so i don't know where to find bios, other memcards etc.

With regards.
Image
By Shood

User avatar
alkarl
Member
Posts: 85
Joined: Thu Nov 26, 2009 7:22 am

Re: Vagrant Story Corrupted Saves

Postby alkarl » Sat Jan 02, 2010 11:17 pm

for the bios if you don't have friends ask google,
the bios can have different filenames,
NTSC version: scph-1001, scph-5001, scph-5501, scph-7001, scph-7501,
PAL version: scph-1002, scph-5002, scph-5502, scph-7002, scph-7502.

for the memory cards,
the native filename format used by fpsece is .mcd,
to convert it to other format i always recommend PSXGamEdit:
http://moberg-dybdal.dk/psxge/psxge160.zip.
here are the memory card formats supported by fpsece:
- PsEmu images (*.mcd)
- Bleem! images (*.mcr)
- Raw images (*.raw)
- VGS images (*.vgs,*.mem)
- DexDrive images (*.gme)
- DataDeck images (*.ddf)
try loading an ingame save from an already full memcard,
if it's loading then try overwriting that same existing block,
if you don't have one download some from here:
http://www.gamefaqs.com/console/psx/save/914326.html

by disabling speed hacks (skipping or modifying normal cycles) i meant setting to zero all the following section from your FPSECE.INI:
Odd_Even_Fix=0
Busy_Fix=0
Lazy_Update_Fix=0
High_Res_Boot_Fix=0
Frame_Skip_Mode=0
disabling frameskip also count as one.

a PAL version of the game would be the french version of vagrant story, if you are successful then you could try converting you english iso to a PAL version using some tools.

if you could just copy and past the content of your fspse.ini file in here it would be useful.
IPAQ 210

Screen: 640x480 VGA 4 inch
Keyboard: d-pad, 6 keys
Memory: 128MB Ram, 256MB Rom
CPU: Marvell PXA310 625Mhz

User avatar
Assasin
Member
Posts: 91
Joined: Sat Jan 02, 2010 6:46 pm
Primary Device: Sony Ericsson Xperia x1
Operating System: 6.1
ROM: stock

Re: Vagrant Story Corrupted Saves

Postby Assasin » Sun Jan 03, 2010 10:50 am

Code: Select all

 [FPSE]
DisclaimerAgree=1
LastGPU=gpusoftdx.dll
LastSPU=0peopspu109.dll
LastJOY0=joy0pse.dll
LastJOY1=joy1key.dll
LastCD=cdrimage.dll
LastPAR=parnull.dll
CDCountry=1
UseOtherMDEC=off
CDUseCache=off
CDCacheSize=16384
CDStreamSpeed=0
CpuMode=on
CpuMode2=off
ShowGenCode=off
AutoSpeed=on
MDEC_bw=off
DisableEngines=off
DisableLogo=on
EnableHLE=off
EmuConsole=off
UseSubQ=on
CacheSubQ=off
BiosName=SCPH1001.BIN
RomName=SCPH1001.BIN
MemCard1=slot1.mcd
MemCard2=slot2.mcd
ArmCoreV5=on
ArmCoreMMX=off
UseSerial=off
ComPort=COM2
Verbose=off
Disasm=off
Debugger=off
EnablePCDRV=off
PCDRV_RO=off
CDDA2SPU=off
HideMouseCur=off
RunSPUsync=off
SmartChnRead=off
EnableDatel=off
IgnoreCdErrs=on

[PocketPC]
Onscreen_OC14=0
Onscreen_O14=0
Onscreen_14=0
Onscreen_OC13=0
Onscreen_O13=0
Onscreen_13=0
Onscreen_OC12=0
Onscreen_O12=0
Onscreen_12=0
Onscreen_OC11=0
Onscreen_O11=0
Onscreen_11=0
Onscreen_OC10=0
Onscreen_O10=0
Onscreen_10=0
Onscreen_OC09=0
Onscreen_O09=0
Onscreen_09=0
Onscreen_OC08=0
Onscreen_O08=0
Onscreen_08=0
Onscreen_OC07=0
Onscreen_O07=0
Onscreen_07=0
Onscreen_OC06=0
Onscreen_O06=0
Onscreen_06=0
Onscreen_OC05=0
Onscreen_O05=0
Onscreen_05=0
Onscreen_OC04=0
Onscreen_O04=0
Onscreen_04=1
Onscreen_H=3
Onscreen_W=5
Onscreen_OC03=0
Onscreen_O03=0
Onscreen_03=0
Onscreen_OC02=0
Onscreen_O02=0
Onscreen_02=0
Onscreen_OC01=0
Onscreen_O01=0
Onscreen_01=0
Onscreen_OC00=0
Onscreen_O00=0
Onscreen_00=5
Main_Volume=1
Da_Volume=1
Xa_Volume=1
Isos_PATH=\Karta pamięci\Moje
GFXDRV=2
Orientation=0
FpsCount=on
EnableSound=on
Stretch_x=0
Stretch_y=0
Start_y=10
SoundVolume=10
PadType=1
FullScreen=1
Stick_Left=0
Stick_Right=0
Stylus_Wide=20
Sensor_Zx=700
Sensor_Gpz=127
Sensor_Mpz=200
Sensor_Npz=20
Sensor_Gpx=127
Sensor_Mpx=200
Sensor_Npx=20
Stylus_Mode=1
Sensor_Mode=0

[GPUSOFT]
Odd_Even_Fix=0
Busy_Fix=0
Lazy_Update_Fix=0
High_Res_Boot_Fix=0
Frame_Skip_Mode=0

[JOY0KEY]
AutoRotate=0
MultiFix_GunB=0
MultiFix_GunA=0
MultiFix_Left=16777344
MultiFix_Down=16777220
MultiFix_Right=524288
MultiFix_Up=4
MultiFix_Select=50331680
MultiFix_Start=33554464
MultiFix_Quadrangle=34078720
MultiFix_Triangle=33554448
MultiFix_Circle=34603008
MultiFix_Cross=50331664
MultiFix_L1=0
MultiFix_L2=0
MultiFix_R1=0
MultiFix_R2=0
MultiFix=0
Button8=0
Special8=0000000000000000
Button7=0
Special7=0000000000000000
Button6=0
Special6=1000000000000000
Button5=0
Special5=0000000010000000
GunB=87
GunA=81
Up=69
Down=88
Left=83
Right=70
Start=112
Select=113
Triangle=80
Quadrangle=76
Circle=8
Cross=13
L1=0
L2=86
R1=0
R2=66
Special1=1000000010000000
Button1=87
Special2=0010000010000000
Button2=82
Special3=0001000001000000
Button3=0
Special4=0001000010000000
Button4=79

[JOY1KEY]
Up=38
Down=40
Left=37
Right=39
Start=112
Select=113
Triangle=69
Quadrangle=83
Circle=68
Cross=88
L1=81
L2=87
R1=82
R2=84
Device=0
Switch=8
An1Up=89
An1Down=66
An1Left=71
An1Right=72
An1Action=86
An2Up=73
An2Down=77
An2Left=74
An2Right=75
An2Action=78

[SPUPeops]
UseXA=1
Volume=1
XAPitch=0
UseTimer=0
SPUIRQWait=0
DebugMode=0
RecordMode=0
UseReverb=0
UseInterpolation=0
DisStereo=0
UseDBufIrq=1


This is my fpse.ini.
I am using PAL version of Vagrant Story. I use Polish Version of this game. :D :D
I will try your advices. If it will be still corrupted, i will write here.
Image
By Shood

User avatar
Q-Ball
Global Moderator
Posts: 850
Joined: Tue Jan 13, 2009 5:55 pm
Primary Device: Sony Ericsson Xperia Mini pro
Operating System: Android 2.3.2
Contact:

Re: Vagrant Story Corrupted Saves

Postby Q-Ball » Sun Jan 03, 2010 3:12 pm

I hope you save your game without Frameskip?
Image

User avatar
Assasin
Member
Posts: 91
Joined: Sat Jan 02, 2010 6:46 pm
Primary Device: Sony Ericsson Xperia x1
Operating System: 6.1
ROM: stock

Re: Vagrant Story Corrupted Saves

Postby Assasin » Sun Jan 03, 2010 5:33 pm

Yes i am saving game without frameskip and it is the same as with frameskip...

I've tried your advices with bios, memcards and still don't work :( any other ideas?
Image
By Shood

User avatar
alkarl
Member
Posts: 85
Joined: Thu Nov 26, 2009 7:22 am

Re: Vagrant Story Corrupted Saves

Postby alkarl » Mon Jan 04, 2010 7:33 am

i finally managed to reproduce your problem with a PAL (patched) version of vagrant story and i ran a series of tests so here are the results:

Odd_Even_Fix=0 (loop if set to 1)
Busy_Fix=0 (loop if set to 1)
Lazy_Update_Fix=0 (loop if set to 1)
High_Res_Boot_Fix=0 (menu glitched if set to 1)
Frame_Skip_Mode=1 (always on for me)

EnableHLE=off
the last was the culprit for my case, disabled it and the problem was solved, but you mustn't let the intro movie finish on it's own (try to skip all the MDEC movies) if you don't want to get stuck in a loop, also you will experience some frame drop in the first intro movie, had it fullspeed with HLE=on and PAL mode but not with NTSC.

but since i see that you already have HLE set to off then this can be some sort of combination that i'll try to figure out later so here is my setting's file:

[FPSE]
DisclaimerAgree=1
LastGPU=gpusoftdx.dll
LastSPU=0peopspu109.dll
LastJOY0=joy0pse.dll
LastJOY1=joy1key.dll
LastCD=cdrimage.dll
LastPAR=parnull.dll
CDCountry=1
UseOtherMDEC=on
CDUseCache=off
CDCacheSize=16384
CDStreamSpeed=0
CpuMode=on
CpuMode2=off
ShowGenCode=off
AutoSpeed=on
MDEC_bw=off
DisableEngines=on
DisableLogo=on
EnableHLE=off
EmuConsole=off
UseSubQ=on
CacheSubQ=on
BiosName=SCPH1001.BIN
RomName=SCPH1001.BIN
MemCard1=slot1.mcd
MemCard2=slot2.mcd
ArmCoreV5=on
ArmCoreMMX=on
UseSerial=off
ComPort=COM2
Verbose=on
Disasm=on
Debugger=off
EnablePCDRV=on
PCDRV_RO=on
CDDA2SPU=on
HideMouseCur=off
RunSPUsync=off
SmartChnRead=on
EnableDatel=off
IgnoreCdErrs=on

[PocketPC]
Onscreen_OC14=0
Onscreen_O14=0
Onscreen_14=0
Onscreen_OC13=0
Onscreen_O13=0
Onscreen_13=0
Onscreen_OC12=0
Onscreen_O12=0
Onscreen_12=0
Onscreen_OC11=0
Onscreen_O11=0
Onscreen_11=0
Onscreen_OC10=0
Onscreen_O10=0
Onscreen_10=0
Onscreen_OC09=0
Onscreen_O09=0
Onscreen_09=0
Onscreen_OC08=0
Onscreen_O08=0
Onscreen_08=0
Onscreen_OC07=0
Onscreen_O07=0
Onscreen_07=0
Onscreen_OC06=0
Onscreen_O06=0
Onscreen_06=0
Onscreen_OC05=0
Onscreen_O05=0
Onscreen_05=0
Onscreen_OC04=0
Onscreen_O04=0
Onscreen_04=1
Onscreen_H=3
Onscreen_W=5
Onscreen_OC03=0
Onscreen_O03=0
Onscreen_03=0
Onscreen_OC02=0
Onscreen_O02=0
Onscreen_02=0
Onscreen_OC01=0
Onscreen_O01=0
Onscreen_01=0
Onscreen_OC00=0
Onscreen_O00=0
Onscreen_00=5
Main_Volume=1
Da_Volume=1
Xa_Volume=1
Isos_PATH=\SD Card\emu\Roms
Orientation=0
FpsCount=on
EnableSound=on
Stretch_x=0
Stretch_y=0
Start_y=0
SoundVolume=10
PadType=1
FullScreen=1
Stick_Left=0
Stick_Right=0
Stylus_Wide=20
Sensor_Zx=700
Sensor_Gpz=127
Sensor_Mpz=200
Sensor_Npz=20
Sensor_Gpx=127
Sensor_Mpx=200
Sensor_Npx=20
Stylus_Mode=1
Sensor_Mode=0
GFXDRV=1

[GPUSOFT]
Odd_Even_Fix=0
Busy_Fix=0
Lazy_Update_Fix=0
High_Res_Boot_Fix=0
Frame_Skip_Mode=1

[JOY0KEY]
AutoRotate=0
MultiFix_GunB=0
MultiFix_GunA=0
MultiFix_Left=16777344
MultiFix_Down=16777220
MultiFix_Right=524288
MultiFix_Up=4
MultiFix_Select=50331680
MultiFix_Start=33554464
MultiFix_Quadrangle=34078720
MultiFix_Triangle=33554448
MultiFix_Circle=34603008
MultiFix_Cross=50331664
MultiFix_L1=0
MultiFix_L2=0
MultiFix_R1=0
MultiFix_R2=0
MultiFix=0
Button8=0
Special8=0000000000000000
Button7=0
Special7=0000000000000000
Button6=0
Special6=1000000000000000
Button5=0
Special5=0000000010000000
GunB=87
GunA=81
Up=69
Down=88
Left=83
Right=70
Start=112
Select=113
Triangle=80
Quadrangle=76
Circle=8
Cross=13
L1=0
L2=86
R1=0
R2=66
Special1=1000000010000000
Button1=87
Special2=0010000010000000
Button2=82
Special3=0001000001000000
Button3=0
Special4=0001000010000000
Button4=79

[JOY1KEY]
Up=38
Down=40
Left=37
Right=39
Start=112
Select=113
Triangle=69
Quadrangle=83
Circle=68
Cross=88
L1=81
L2=87
R1=82
R2=84
Device=0
Switch=8
An1Up=89
An1Down=66
An1Left=71
An1Right=72
An1Action=86
An2Up=73
An2Down=77
An2Left=74
An2Right=75
An2Action=78

[SPUPeops]
UseXA=1
Volume=1
XAPitch=0
UseTimer=0
SPUIRQWait=0
DebugMode=0
RecordMode=0
UseReverb=0
UseInterpolation=0
DisStereo=0
UseDBufIrq=1
IPAQ 210

Screen: 640x480 VGA 4 inch
Keyboard: d-pad, 6 keys
Memory: 128MB Ram, 256MB Rom
CPU: Marvell PXA310 625Mhz

User avatar
Assasin
Member
Posts: 91
Joined: Sat Jan 02, 2010 6:46 pm
Primary Device: Sony Ericsson Xperia x1
Operating System: 6.1
ROM: stock

Re: Vagrant Story Corrupted Saves

Postby Assasin » Mon Jan 04, 2010 5:10 pm

Hehehehehe...
I've configured it as you said and now the fpsece is crashing just after load image.
Image
By Shood

User avatar
CloudStrife86
Global Moderator
Posts: 1272
Joined: Sun Apr 26, 2009 12:07 am
Primary Device: Samsung Galaxy S4 (i9505)
Operating System: Android
ROM: Stock Jelly Bean 4.2.2
Location: Durham, United Kingdom
Contact:

Re: Vagrant Story Corrupted Saves

Postby CloudStrife86 » Mon Jan 04, 2010 5:26 pm

Assasin wrote:Hehehehehe...
I've configured it as you said and now the fpsece is crashing just after load image.

If you change the line "DisableLogo=on" to "DisableLogo=off", do you get the Sony logo after trying to load an image?
Image
Platinum trophies: Uncharted, MW2, Uncharted 2, Resi 5, AC II, Fallout 3, Batman: AA, CoD: WaW, BlOps, FFXIII, BioShock, L.A. Noire, Deus Ex: HR, Uncharted 3, Heavy Rain, Batman: AC, inFAMOUS 2, The Walking Dead, Virtue's Last Reward, Borderlands


Return to “General Discussion”

Who is online

Users browsing this forum: No registered users and 1 guest