View unanswered posts | View active topics It is currently Thu Oct 02, 2014 4:23 am




Reply to topic  [ 6 posts ] 
 Xperia Play with OpenGL plugin 
Author Message
Fresh Fish

Joined: Tue Apr 10, 2012 8:52 pm
Posts: 1
Primary Device: Xperia Play
Operating System: Android
ROM: 2.3.4 (bootloader unlocked)
Post Xperia Play with OpenGL plugin
Hi

What settings are people using to get a good performance from the OpenGL plugin?

Is anyone using a custom rom or overclocking?

Thanks


Thu May 03, 2012 12:43 pm
Profile
Junior Member

Joined: Fri May 04, 2012 1:32 pm
Posts: 8
Primary Device: Xperia Play
Operating System: Android
ROM: Stock SE Xperia Play
Post Re: Xperia Play with OpenGL plugin
I am using stock rom that comes with xperia play with no overclocking and the performance is great when playing with the original screen size, fullscreen (resized) can cause the game to slow down. Getting 60 fps on games like Grandia.

But I'm experiencing a 'small' problem with the opengl plugin though: it draws on the sides of the screen where it should be black.

Is this a known problem? Searched the forum but found no one complaining.
Is there any particular option I should use to make it go away? Tried several combinations of enabling/disabling options but nothing helped.

screenshots:
Attachment:
File comment: grandia with opengl full screen size
screenshot_2012-04-30_1156.gif
screenshot_2012-04-30_1156.gif [ 74.41 KiB | Viewed 2897 times ]

Attachment:
File comment: grandia with opengl original screen size
screenshot_2012-04-30_1152.gif
screenshot_2012-04-30_1152.gif [ 80.04 KiB | Viewed 2897 times ]


Fri May 04, 2012 1:52 pm
Profile
Fresh Fish

Joined: Mon May 07, 2012 1:42 am
Posts: 2
Primary Device: galaxy s
Operating System: android
ROM: jvu
Post Re: Xperia Play with OpenGL plugin
opengl plugin works great if you disable every filtering from video menu, especially alpha multipass and advanced blending, but i have small issue with it, in tekken3 when i play on first stage and stage appears then its good for first 1/5 of second then goes corrupted, wrong textiures are in bad places, then in next stage when enemy is being loaded and stage is being loaded it looks fine but still my character textures are corrupted and health bar is corrupted so there have to be something with loading first stage that makes textures corrupted like that, theyre getting fixed in second stage but this lifebar stays corrupted and my character texture.Is it possible to fix this behaviour? Im on galaxy S, when i turn on advanced blending then this problem goes away but i have major unplayable slowdown.


Mon May 07, 2012 1:50 am
Profile
Junior Member

Joined: Sun Jun 10, 2012 3:45 pm
Posts: 6
Primary Device: Xperia Play
Operating System: Android 2.3.4
ROM: Stock
Post Re: Xperia Play with OpenGL plugin
I diasabled all the filters but I still get some ugly results in MGS.
Seems like we have to wait for further optimisation on the OpenGL plugin.


Attachments:
screenshot_2012-06-10_1739.png
screenshot_2012-06-10_1739.png [ 78.12 KiB | Viewed 2628 times ]
Sun Jun 10, 2012 3:49 pm
Profile
Junior Member

Joined: Mon Sep 17, 2012 7:20 pm
Posts: 15
Primary Device: Xperia Play
Operating System: Android Gingerbread
ROM: NXT Light Edition + DoomKernel
Post Re: Xperia Play with OpenGL plugin
Im using ROM Xperia NXT Light edition, and overclocked to 1.8
I have readed some people use Swapper also but i dont have a good SD card.(low class)

Im playing FF9 now i get 50 fps in non combat and in combat it runs very well but i havent got any special summon yet...like Shiva or ifrit....those things made me stop testing FF8 because ifrit made me so slow like less than 10 fps.

But in other games it runs a lot better...i play without frameskip and with special frame limiter... Usually boost bios helps if im not wrong.

And to be honest i dont know what else to do to improve my opengl experience :p

But Open GL ES 2 run really good...the software filter its not heavy and laggy like before.

Sorry for my bad english :3


Thu Sep 27, 2012 2:54 am
Profile
Fresh Fish

Joined: Sun Dec 30, 2012 4:21 am
Posts: 2
Primary Device: Sony Ericsson Xperia Play
Operating System: Android 2.1
ROM: stock
Post Re: Xperia Play with OpenGL plugin
Xenogears is extremely slow and glitchy with OpenGL enabled. Software mode is a lot better but it slows to less than 1fps during some cutscenes and has noticeable graphical glitches everywhere.

I'm using stock ROM, no overclocking or anything.


Fri Jan 04, 2013 12:57 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 6 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.