Can't get memory cards to work

Hobbiticus
Junior Member
Posts: 5
Joined: Fri Jun 14, 2013 3:20 am
Primary Device: Galaxy S 2
Operating System: Android
ROM: stock

Can't get memory cards to work

Postby Hobbiticus » Fri Jun 14, 2013 3:44 am

Just got the emulator, and I have to say I'm impressed with how well it runs.

However, I have one problem: memory card support doesn't seem to work. I've tried literally everything I could think of but to no avail.

My setup:
Samsung Galaxy S2
Android 4.1.2 (not jailbroken, not rooted, completely stock)
BIOS scph1001.bin
Final Fantasy 7, and Final Fantasy Tactics

I'm able to "format" the memory card, but when I actually go to save a game, it says that there is not enough space available. I've tried the stock location and I've tried a custom location on my SD card. I tried creating an empty .mcd file in the path of where the memory card should be. I tried creating a 1MB file full of zeros. I tried resetting fpse to default settings and starting over. I tried googling around, but there don't seem to be many answers out there.

The one clue I do have is when I backed up all files, my log file looks like this:
FPSE - Fast PlayStation Emulator
Android Version 0.11 by FPSE team
BUILD May 26 2013 23:27:33

Porting done by Schtruck

Initializing system...
---------------------------------------------------------
(.) Allocating memory blocks...
(.) Initializing hardware resources...
-> (!) Error opening memcard1 file /storage/sdcard0/.fpse/memcards/slot1.mcd
-> (!) Error opening memcard1 file slot1.mcd
-> (!) Error opening memcard2 file /storage/sdcard0/.fpse/memcards/slot2.mcd
-> (!) Error opening memcard2 file slot2.mcd
(.) Initializing CDROM engine.
-> (.) SCEI zone selected.
(.) Geometry Transformation Engine...
-> (.) Using DSP V5 GTE engine.
(.) Motion Decoder Engine...
-> (.) Using Portable MDEC engine
(.) Initializing BIOS resources...
-> (.) Loading '/storage/extSdCard/PlayStation/BIOS/scph1001.bin'...
(.) Loading files...
-> (.) Game License: (null)

Opening console...
---------------------------------------------------------
Shutting down compiler...


This particular case is after I reset all of my settings, so it's using the default memory card location. The same thing happens if I point it to a location on my SD card, even if none of the directories start with a dot.

Normally, I'd be perfectly happy using save states, but I know that I'm going to need the memory card to move to disk 2 of FF7.

Any ideas?

User avatar
schtruck
Site Admin
Posts: 2113
Joined: Tue Jan 13, 2009 8:52 am
Primary Device: HTC HD2
Operating System: WM 6.5.1 21869
ROM: 1.66
Location: PARIS
Contact:

Re: Can't get memory cards to work

Postby schtruck » Sun Jun 16, 2013 10:40 am

Does those files are well existing into this path?

Hobbiticus
Junior Member
Posts: 5
Joined: Fri Jun 14, 2013 3:20 am
Primary Device: Galaxy S 2
Operating System: Android
ROM: stock

Re: Can't get memory cards to work

Postby Hobbiticus » Sun Jun 16, 2013 4:13 pm

I've tried both creating those files and deleting those files. The same thing happens whether or not those files exist.

Do I need to download an existing .mcd file in order for it to work?


Return to “General Discussion”

Who is online

Users browsing this forum: No registered users and 8 guests