Page 1 of 1

FPse runs on HLE but not with BIOS

Posted: Tue Oct 09, 2012 2:03 pm
by Birdman94
Hey there :)

I've been scoping out the threads and googling for this issue but it doesn't seem to have popped up anywhere! I've just recently purchased FPse and it runs games perfectly when no BIOS is loaded (HLE mode) but when the BIOS (scph1001) is selected and the game is loaded the on-screen controls show up for a brief instant (< second) and then goes back to the FPse home screen (no game load screen appears at all). This is with version 0.11.53 and I know the BIOS is clean because I ripped it myself and it works for my PC emulator. I have the new Australian galaxy S3 4G with Jellybean (4.1.1) so I'm not sure if that could be an issue? Any help would be brilliant! Cheers :)

Re: FPse runs on HLE but not with BIOS

Posted: Wed Oct 10, 2012 12:25 am
by Birdman94
Thanks for the reply!

Yeah I used to enjoy following DIY's especially at uni when I had some spare beer money and was looking for absolutely anything that I could prioritise over my assignments :D

I tried the bios on another phone emulator just to see if it was the issue and it didn't seem to be but I tried another bios on FPse anyway, and it achieved the same result (flashes controls then back to the main menu). It does the same thing when I press the boot bios button after loading it, so it not being a problem with the bios is confusing! The new operating system wouldn't be having an impact would it? As I don't think it's that widely implemented yet (but I'm not entirely sure).

Re: FPse runs on HLE but not with BIOS

Posted: Thu Oct 11, 2012 2:29 am
by Birdman94
Yeah it's certainly a weird one!

As a final check, I installed FPse on my old HTC desire and used the same BIOS and game and everything worked perfectly (even had the same default settings) so it seems to be something to do with the phone unfortunately!

Re: FPse runs on HLE but not with BIOS

Posted: Fri Oct 12, 2012 6:32 am
by schtruck
that's weird, and could explain the problem that somes people are reporting.

how do you transfert or uncompress your bios on your SIII?

Re: FPse runs on HLE but not with BIOS

Posted: Sat Oct 13, 2012 1:23 am
by Birdman94
The bios and game were just on my PC and not compressed in any way, and I just transferred them to my SD card via the USB cable which got me to thinking and I solved the issue :)

A Galaxy SIII (without root access) only allows you to install applications onto the internal storage (in my case this is sdcard0) and NOT onto an external SD card (in my case extSdCard). I had transferred my bios and games into a folder on my external sd card and was trying to boot the bios from there which is why it was not working. I created a folder on my internal storage and put my bios in there, and fpse booted perfectly straight away :)

So in conclusion, you can load games from the external sd card and they work perfectly but the bios MUST be on the phone's internal storage to be able to load it and play games with a bios. Thanks for the help guys and I hope this helps anyone else who may have had the same situation with their Samsung Galaxy SIII or other phones :)