Page 1 of 1

I got a few problems with FPSE 11.29 on my S3

Posted: Mon Jul 09, 2012 11:43 am
by vainglorious
I just bought your app via play store yesterday after seeing it came with some bug fixers on S3.
However, I found out there have been something wrong with the app since the app often freezes itself
and it often notifies me of "please close the app and choose force mono core in the setting".
You know the frame rate is super slow when you force mono core ?

Beside that, now I think I got a bigger problem that is the app asking me to close it by saying
"FPSE has exited, please close other active apps and restart FPSE" something like this (I can't remember clearly, though)
You know, i hadn't open any apps but only FPSE, so i tried to quit it and then open it again but
it still notified me of that. How could I fix this to use it smoothly and happily ?
Before buying it, my friend suggested I buy your app cos it is very effective and worth the money
but now what I found out doesn't live up to my expectation. Hopefully, you will get to fix these kinds of problems for me
and others who have also faced them.

Re: I got a few problems with FPSE 11.29 on my S3

Posted: Tue Jul 10, 2012 12:03 am
by bluezeak
First let me say that FPSE is fantastic, and your friends advice was good advice. Also, know that FPSE gets updated frequestly. If you look at the list of updates that Schtruck has done over the last 6 months you'll see he's updated it a LOT.

There are actually four different models of the S3: one that uses the Mali400 (which is what the fix you read about is for) and 3 that use a different chipset - Adreno 225.

Take a look at my post on opengl. Specifically, look at the hardware section. Follow the link to check your hardware, see what chipset and GPU it uses, and see if there are any notes in there about it. That link is specific to intended for info about OpenGL, but it talks about some gerneral issues as well. If you have the Adreno 225 GPU see here.

Something is wrong though if you're getting a message talking about needing to force mono core. I've heard other users talk about the app not running properly when not running mono core, maybe you have the same issue. I don't know what the answer is for that. However, FPSE should NOT run slow on your device unless you have filtering enabled. turn it off, and see if it runs ok. On my device if I have filtering enabled in the softGPU and I'm in mono-core mode I get 35-45 FPS - is that what you get? Your machine is faster than mine so it should be better I think.

The force close that you're getting sounds odd. I wonder if you have a bad ROM maybe? Do you have this issue with other games as well?

Have you tried the OpenGL? What type of performance do you get with it? If you have the Adreno 225 GPU it will probably be bad.

Re: I got a few problems with FPSE 11.29 on my S3

Posted: Tue Jul 10, 2012 3:42 pm
by vainglorious
I already checked the gpu spec of my S3 and found that the one which has come with S3 releasing here is Mali400, not Adreno225.
By the way, I hadn't tried anything about OpenGL cos I just didn't know what it is for. Nevertheless, as u suggested, now I got to install it on my S3
via the internet but I have no idea about how to adjust the options provided more after installing OpenGL. Could you please give me some advice concerning it ?

As for my messages about mono core, I would like to say that the game runs very slow when I force mono core as the app asks me to. When I don't adjust to forcing
mono core, the game runs very smooth but I can't just play it sometimes since the app gives me that message to run mono core during the game once in a while.
Also, I haven't had filtering enabled in the softGPU because I didn't change anything in the settings about the graphics, I just did something about the joypad is all.
How do I notice how many FPS I get when switching to mono core ?

As for the force closing, I think it's not about the ROM cos the one I'm on at the moment is the original one that came with the device. Anyway, I think it might be
about the game "Harvest Moon: Back to the Future". Perhaps, FPSE has something wrong with the game. I just tried only this game on my device, haven't tried any
other games yet. Did you try "Harvest Moon: Back to the Future" on your device ?

If it's possible, please help me to fix these problems. I'm very new to FPSE. Thank you a million.

Re: I got a few problems with FPSE 11.29 on my S3

Posted: Tue Jul 10, 2012 4:32 pm
by bluezeak
Check my link on OpenGL. I linkned to it in my first post, put I'll link it here explicitly.

Specifically, click on the Google Docs link to get more info on the options for OpenGL. Initially you probably should leave all the options off except Print FPS and probably framelimiter. You may need frameskip also. Sometimes framlimiter + frameskip gives worse performace so you might need 'special framlimiter' instead of 'framelimiter'. In addition, you may need offscreen drawing and alpha multipass, you can start with those or you can wait and try them if there are issues. If you change the offscreen drawing and multipass you will likely need to exit and reload game for change to take effect. Most of the rest of the options are for enhanced graphics/colors or for special fixes.

I don't have a mali-400 GPU, so I don't have any experience with it. But, the release notes on the latest version of FPSE (11.29) say that you shouldn't need to do anything - shouldn't need the dynamic interpreter from system options or go through special BIOS setup via loading tekken.

Your CPU is very powerful, and you should not have any issues with monocore in software mode (softGPU) as long screen filtering is not enabled. Verify that it is not enabled. If it is not enabled and you still get low FPS then ... something else is wrong.

To show FPS (frames per second) enable it in the video options (Print FPS).

I still think the issue may be with that specific game. Try another game. I'll try that game if I can. Is it "Havest Moon: Back to Future" or is it "Harvest Moon: Back to Nature"?

Also, from looking at old threads here on the forums I see that "Harvest Moon: Back to Nature" (Harvest Moon: BTN) is one of the most difficult games to emulate, along with Tekken3 - at least I think so. click here for more info.

About sound: from looking at the fourms it looks like you need the 'spusync' enabled in the sound options. That won't make it play faster though.

Re: I got a few problems with FPSE 11.29 on my S3

Posted: Wed Jul 11, 2012 4:15 am
by bluezeak
Ok, I was able to test Harvest Moon Back to Nature.

OpenGL and SoftGPU worked about the same for me. About the same FPS on both - which is VERY surprising. The SoftGPU should be much faster. They both ran around 57 FPS, with a couple parts (like in the corner in town) it dropped to 45 FPS - but that was abnormal. If I ran the softGPU with screenfiltering, FPS dropped to ~30, but that's normal. If I turn on dualcore (disable monocore) then it runs > 60, so I have to use framelimiter. But then it's very very choppy - more so than in other games.

So, that's how that game runs for me - it's unusual for the softGPU to run so slow for me (less than 60 FPS). Now, considering that the game runs under 60 FPS in SoftGPU I would think that OpenGL would run very poor. But - it runs just as good in this game - that is to say, it runs just about perfectly.

About quality differences - the two look just about the same. OpenGL is better, mostly in the 3D background elements (tables, other things). But, it's pretty minor.

Re: I got a few problems with FPSE 11.29 on my S3

Posted: Sun Jul 15, 2012 1:11 am
by Hiro14
I received the same error while playing Xenogears on my S3. I was using the software GPU. It seems like it happens alot when I have framelimiter off. When I receive the error and turn "force mono core" on then my framerate is quite poor (aka less than 60 most of the time). Its a double edge sword to have the newest hardware. Huge capability but it cannot be utilized until time passes. Is there anything we can do to help the developer fix some of these performance issues?

Re: I got a few problems with FPSE 11.29 on my S3

Posted: Sun Jul 15, 2012 5:17 am
by bluezeak
Get Samsung to release updated drivers? that was the main issue with the adrenaline 220 gpu