Problems with Open GL plugin

armac911
Fresh Fish
Posts: 3
Joined: Wed May 09, 2012 5:12 am
Primary Device: Motorola Milestone A853
Operating System: Android
ROM: Cyanogenmod 7.2.0

Problems with Open GL plugin

Postby armac911 » Wed May 09, 2012 5:23 am

Hi. I bought FPSe yesterday and so far it has been great except for the OpenGL plugin. If I enable it all games crash on the loading screen after the main menu. Eg. Carmagedon crashes on the loading screen of the race itself, Fifa 2005 crashes when the match is about to start etc. Suddenly I am booted from the game and the LOAD ISO selector appears. No error or anything.

I also tried Chainfire 3D. If I select Reduce Texture Size and Reduce Texture resolution, it works. However every text and 2D graphic is screwed. Also when in OpenGL mode I am not experiencing increased FPS, just better visuals (like filtering etc).

It sounds like it's running out of ram, but without the plugin everything works perfectly.

My device is:

Motorola Milestone A853
Cyanogenmod 7.2.0
1 Ghz Cortex-A8 (PowerVR SGX530)
256 mb ram (110 mb free RAM after stopping services)
Latest FPSe from the market.

armac911
Fresh Fish
Posts: 3
Joined: Wed May 09, 2012 5:12 am
Primary Device: Motorola Milestone A853
Operating System: Android
ROM: Cyanogenmod 7.2.0

Re: Problems with Open GL plugin

Postby armac911 » Wed May 09, 2012 6:14 pm

Just noticed, when I turn on "Advanced Blending" in the video options, all of the games load, but I am getting 8 to 12 fps. Its software for me I guess.

One more question. How do I know when a game is running at full speed? Is 25+ fps enough? Or is it measured differently (like in dolphin?)

saphendym
Fresh Fish
Posts: 4
Joined: Sun Jun 26, 2011 5:08 pm
Primary Device: HTC G2
Operating System: Android
ROM: stock

Re: Problems with Open GL plugin

Postby saphendym » Wed May 16, 2012 10:44 pm

I think everyone has speed problems with the openGL plugin, or maybe just most people. The feature was literally *just* added so it will likely take a while to become fully optimized. Just stick with the software renderer for now.

To see if a game is running at full speed, load up a game and hit the menu key, then settings, then video, the check "Print FPS." In the game it should be capped out at 59/60 the whole time (you'll see it in the upper left corner of the screen.) If it goes below this. Try enabling boost mode in the system settings, and if that still doesn't fix it then enable frame skipping as well.


Return to “General Discussion”

Who is online

Users browsing this forum: No registered users and 20 guests