Fpse for Android News

User avatar
schtruck
Site Admin
Posts: 2123
Joined: Tue Jan 13, 2009 8:52 am
Primary Device: HTC HD2
Operating System: WM 6.5.1 21869
ROM: 1.66
Location: PARIS
Contact:

Re: Fpse for Android Discussion/Feedback

Postby schtruck » Thu Sep 06, 2012 5:39 am

@threetz , the log you sent me wasn't complete i need more.

foleyjo
Enthusiast
Posts: 131
Joined: Thu Jun 28, 2012 8:22 pm
Primary Device: JXD S601

Re: Fpse for Android Discussion/Feedback

Postby foleyjo » Thu Sep 06, 2012 6:16 am

bluezeak -

Brightness - I;ve tried those options and it made no difference (Unless I was supposed to reset for them to take effect). Games that seem to bright are GTA and one of the rooms in Overblood.

'attention' - So is there a way to switch to Opengl mid game and still use the same save states or do you have to use it from the start?
With spusync I need to use it for Medal of Honor but if I load my save states with spusync on I get the attention message and then no sound in game.

parasite eve 2 - Force Mono is checked. I have to use it now since the latest batch of updates. Without it I get stuttering in all games. Framelimiter is on and frameskip is set to 0. I have tried it with exactly the same options as when it was working. Previously I got to the hospital (and then died). Now I can't get out of the first couple of rooms.

2d sound - The one I test with is Bust A Groove. On the language selection and option screens it plays a sound when you change option. There is a big delay with this sound. Makes it difficult to play as the flashing button indicator doesn't match the music. I've noticed it on other games options and 2D screens and the delay is there also. For example the title screen of overblood. The animations on Parrappa tha Rappa seem out of sync too but the music and button presses are in sync. The problem wasn't that bad a couple of updates back. It was still there but very slight. Now it's very obvious.

User avatar
schtruck
Site Admin
Posts: 2123
Joined: Tue Jan 13, 2009 8:52 am
Primary Device: HTC HD2
Operating System: WM 6.5.1 21869
ROM: 1.66
Location: PARIS
Contact:

Re: Fpse for Android Discussion/Feedback

Postby schtruck » Thu Sep 06, 2012 6:19 am

which device and android version do you have foleyjo?

Because i try many title and sound is perfect or just close to perfectly synced. it's perhaps related to the Multi more option and thread priority.

deejayzee
Member
Posts: 56
Joined: Wed May 23, 2012 11:31 am
Primary Device: Galaxy Tab 2 7''
Operating System: JB 4.1.2
ROM: AOKP

Re: Fpse for Android Discussion/Feedback

Postby deejayzee » Thu Sep 06, 2012 7:57 am

I can't hear any difference in sound too. Music in Persona sounds like a couple of channels was muted, menu switching sounds not always reproduced, and it seems not all sound effects work
FPse saves video settings for every game but not mono/dual core option, I can't remember exactly if it worked in the earlier builds
Last edited by deejayzee on Thu Sep 06, 2012 8:11 am, edited 1 time in total.

foleyjo
Enthusiast
Posts: 131
Joined: Thu Jun 28, 2012 8:22 pm
Primary Device: JXD S601

Re: Fpse for Android Discussion/Feedback

Postby foleyjo » Thu Sep 06, 2012 8:10 am

I'm using JXD S601 with android 2.3 .

The sound is fine 99% of the time so it is a hard one to pick up on. It is only with the 2D graphics I ever notice it.
I've just tried changing the thread settings and it made no noticeable difference.
When I don't force mono core the fps indicator keeps flashing on and off. Not sure if this is actually affecting the game being played though but I leave mono core on just in case. It made no difference to the lag anyway.

If you have bust a groove on the language selection or the option screen just move up and down. When I do it the sound effect comes about 1 second after the cursor actually moves.
Same happens in overblood at the title screen but as soon as you get into the game (where it's in 3D) the sound is perfectly synced.

User avatar
bluezeak
Guru
Posts: 600
Joined: Fri Feb 03, 2012 10:04 am
Primary Device: motorola bionic
Operating System: Android 2.3.4
ROM: stock

Re: Fpse for Android Discussion/Feedback

Postby bluezeak » Thu Sep 06, 2012 8:28 am

foleyjo wrote:bluezeak -

Brightness - I;ve tried those options and it made no difference (Unless I was supposed to reset for them to take effect). Games that seem to bright are GTA and one of the rooms in Overblood.

'attention' - So is there a way to switch to Opengl mid game and still use the same save states or do you have to use it from the start?
With spusync I need to use it for Medal of Honor but if I load my save states with spusync on I get the attention message and then no sound in game.

OpenGL - you need to restart fpse for options to change. I think the help says there are only 3 that need you to restart - in my experience you need to restart for almost all options to take effect except framelimiter and frameskip.

you cannot change opengl (or softgpu) during game, you must restart. SPUSync - you must restart if you change this option.

so, cahnge the option, restart, laod game, then load save state.

Also, do not rely on save states. Always, always, save to memory card. save states can have problems. you can use save states, but do not rely on them.
FPSE OpenGL info - click here

Keram
Junior Member
Posts: 8
Joined: Wed Sep 05, 2012 1:00 pm
Primary Device: Sony Ericsson NEO V
Operating System: Android 2.3.4
ROM: STOCK

Re: Fpse for Android Discussion/Feedback

Postby Keram » Thu Sep 06, 2012 8:30 am

Sound is now almost perfect. I have no sound issues in Chrono Cross and FF series, but still i have sound issues for exaple in Suikoden II intro movie.
About my previous problem (lost savestates and memorycards) - after this update was even worse. Even manualy copied memory cards and save states didn't work. But after reinstalling fpse, i have manualy copied memorycads and savestates from my sdcard/fpsebackup into my sdcard/.fpse folder (Tatal Commander or ASTRO file Viewer are very helpfull for this), and now everything is fine.
Good advice for every non experienced android user (like me:) is to make backup fpse files (in fpse options), and if you encountner any problem after update, you should reinstall fpse and copy proper folders into sdcard/.fpse folder, and everything would be ok.

foleyjo
Enthusiast
Posts: 131
Joined: Thu Jun 28, 2012 8:22 pm
Primary Device: JXD S601

Re: Fpse for Android Discussion/Feedback

Postby foleyjo » Thu Sep 06, 2012 8:32 am

sorry when I said about changing mid-game I meant if you have a save state without opengl can you then switch to opengl and load the save state.

I think from what you said though the best option is to find a real save point in the game to save, make the opengl/spusync switch and then load the game from the save point.

User avatar
Tumalu
Junior Member
Posts: 30
Joined: Sat Aug 25, 2012 11:13 am
Primary Device: Samsung Galaxy SII

Re: Fpse for Android Discussion/Feedback

Postby Tumalu » Thu Sep 06, 2012 8:41 am

blue_dusk wrote:Hi all, I'm new to these forums.

My question is about ff7 as of the last 3 or 4 updates of fpse (up to and including .37). The music is sounding very strange, slowing down and speeding up drastically in-game. I've got a backup of .28 in which the audio runs fine... I've tried adjusting a large amount of settings both in the GUI and .ini.

Any help would be much appreciated... I'm running ICS on a SGS2.

Actually I can confirm the same and I have a Galaxy SII as well, is it related? Games ran best for me too on version 0.28 and before while it should actually become better only with each new version. Hope this can be solved. Also with the thread priority, it doesn't really matter what I am setting it to, games never run really smooth and it didn't had this either on much older versions. Screen filtering seemed to have worked better also on previous versions.

User avatar
bluezeak
Guru
Posts: 600
Joined: Fri Feb 03, 2012 10:04 am
Primary Device: motorola bionic
Operating System: Android 2.3.4
ROM: stock

Re: Fpse for Android Discussion/Feedback

Postby bluezeak » Thu Sep 06, 2012 10:24 am

First - the issue I was having with Diablo is resolved. I don't know if the new version fixed it, or if just reinstalling / updating fpse fixed it ... but ... yeay, it works!

About FF7 sound:
    - I've done several tests using the opening credits audio only - I didn't test in the game itself.
      - with and without opengl
      - with and without spusync (need spusync!)
      - with and without "fix distortion"
    - the audio is clearly not right
    - I played the opening credits on epsxe on my computer (connected to my stereo) - WOW! I forgot how good the audio sounded. They sure did a great job with what they had back in those days. The audio plugins I have on epsxe are very different than what's in fpse, I'm sure, so it's not a good comparison (technically). But it really shows the difference from what the sound could / should be.
    - "The music is sounding very strange, slowing down and speeding up drastically in-game" - I didn't test in game, but from the credits, it's not "slowing down and speeding up" - it's more like it's skipping parts.

I didn't test other games, and I assume most other games are good / great. I know schtruck has done a ton of work over the last couple updates working on the sound. We know there's something up with FF7. 10 years ago when we (users) were dealing with emulators on the PC there were several different audio plugins. And there were special fixes that were used for some games / types of games. Some emulators were more compatible, but not as good, others were GREAT! but had lots of options that needed to be configured or didn't work some games. So .... schtruck may be up against the wall. compatibility vs performance. However, he's very good, so we'll see what happens. Personally I think that it's a bit amazing that there's only one sound option (until this last update), and all games ran pretty well. He's keeping it very easy for us so far. It could be a complicated like the opengl plugin - but he's kept it very simple, and works well.
FPSE OpenGL info - click here


Return to “News”

Who is online

Users browsing this forum: No registered users and 13 guests