Page 1 of 1

SaGa Frontier 2

Posted: Sun Nov 04, 2012 7:59 pm
by Mishi
I'm having some issues when starting SaGa Frontier 2 in FPse on my Xperia :/
I'm using the NTSC-U version and whenever I start the game the battle theme just starts playing along with some random sound effects and I get a black screen instead of the title screen.
Is this game compatible with FPse or is it i've got a corrupt game file? I mean I've tried a bunch and every single one has the same problem...

Re: SaGa Frontier 2

Posted: Sun Jun 16, 2013 4:17 pm
by vimes81
I've also had problems with Saga Frontier 2 and FPse
I got some scene where two groups fight, then scene when boy is born (king goes to a castle and names his heir) and then game went blank.
The problem turns out was caused by incorrect game file as in ePSXe I got the same problem.
After finding correct game file its working fine on FPse.

Re: SaGa Frontier 2

Posted: Sun Jun 23, 2013 12:52 am
by helloworld
i tried my copy and it worked fine. i got past the first scene and played the game normally.

your copy is probably corrupted.