Page 1 of 2

Legend of Dragoon

Posted: Sat Jan 21, 2012 9:21 pm
by dannyboy64
I'm pretty new to this, but I also don't see a thread for this game yet, either. My problem is this game doesn't seem to want to play in landscape on my Xperia Play. I can play in portrait with the onscreen pad, but I'd obviously rather use my ps keys Any suggestions?

Re: Legend of Dragoon

Posted: Wed Sep 12, 2012 12:56 pm
by Kethus
Since the new updates that made the screen a bit blurry and the game became faster I started having this problem. During a boss battle, any boss battle, not just the water dragon one, if I go into dragoon form the enemy wont do anything forever and I am also forced to wait so I become stuck and have to restart. To fix the problem I have to turn the dynamic interpreter on, but that way the game becomes very slow and I can't play it. Later the same thing happened during a normal battle, so I can't use the dragoon forms at all. I also can't save the game before any battle, becauce the emulator can't load states made without the interpreter while I have it on.

Also on all the games I've tried the sound is better without the enchanced sound emulatiion thing.

Re: Legend of Dragoon

Posted: Thu Sep 13, 2012 8:50 am
by bluezeak
the enhanced sound setting is optional, it doesn't always help.

have you tried turning off 'hardware acceleration'?

have you tired turning on the system option 'forced monocore'? this may require you to turn off 'filtering' option or it will run too slow.

try these things and report back.

Lastly - DO NOT RELY ON SAVE STATES! Always use the ingame saves. You can still use save states - but they should not be the main way you save the game. use them if you don't have time to get to a normal backup location - but always use the normal backup locations!

Re: Legend of Dragoon

Posted: Thu Sep 13, 2012 10:28 am
by Kethus
Originally I had these options from "SYSTEM" and "VIDEO" switched on and nothing else:
- Fast Boot
- Framelimiter
- Special screen size
- Enhanced 3D rendering
- Hardware acceleration

I played the game for over 33 hours and never had this issue before, then it happened at one boss, I switched to PC, completed it and switched back to android using the backup feature (this is the first time I tried this, the 33 hours were accumulated from several weeks on the phone). Then a second boss came and the situation was the same. Then I tried the Dynamic interpreter and it worked.
After I read your post I found the old memcard file from before beating the two bosses and ran the game with the same settings mentioned above without problem. The battle proceeded normally. Then I wanted to test something else and enabled these options and nothing else:
- Dynamic interpreter
- Fast boot
- Spusync
- Framelimiter
- Special screen size
- Screenfiltering
- Invertcolors*
- Enhanced 3D rendering
- Hardware acceleration

I believed these settings make the most accurate emulation. Now I went to the boss and the problem appeared again, even with the Dynamic interpreter on. The game doesn't freeze. The battles are turn based and when the enemy's turn comes they do nothing and I can't do anything too. Since I can't find about this problem on the internet and I didn't experience it on the PC I assume it doesn't appear on the PC emulator. I also haven't fought any other boss battles since the version of FPse that made the screen blurry and the emulation faster.

*I enabled Invertcolors to see if some textures are going to be fixed, like light blue raindrops being black in FPse and some squares that are supposed to be white are also black and this makes another dark square more difficult to track. It doesn't fix them.

I use memcards when I get the chance, but sometimes the time between two save spots is more than an hour.

edit: well since this is a general LoD thread, I'll submit more stuff I find. I don't use the OpenGL plugin, since my phone doesn't have enough power to run the games smoothly (and for this game I need fast reactions) but when I do I can't get the menus right, I fiddled with the settings a little, but can't make them normal. Nothing game-breaking though.

Re: Legend of Dragoon

Posted: Thu Sep 13, 2012 6:24 pm
by bluezeak
thanks for that nice post.

did you try the things I mentioned? please do. 1st try turning off hardware acceleration. Then try turning on force monocore; when you do you will most likely need to turn off filtering.

you should not need dynamic interpreter. schtruck threw that in to assist with the mail-400 devices that had issues with opengl I believe. it will slow things down and it does the actual emulation of the psx differently. that being said, if it makes games work ... more power to you. try it with that setting off though.

do you like the screen blurring effect? usually I do like it, but it makes games run slow unless I uncheck 'force monocore'. but if I do that, games run kinda choppy as if frameskip were on and skipping lots of frames. sometimes I don't like it. Anyway ...
- the new version will have this on by default, since it uses a new api to do the rendering and it works MUCH better. you will need to go into misc menu to turn on the 'old' setting to turn it off I think.

- did you see my opengl thread? please take a look (see my signatre). sorry it's so long. it has good info. I don't know how to make it shorter without losing info.
- I have two comments about your pic (very nice by the way) - 1) the playstation logo should not be messed up like that. something is seriously wrong. I suggest you post in the main feedback thread saying that opengl causes that issue with the playastation logo (give that link to the pic). It does likely mean your hardware cannot use opengl. 2) the main settings (for all games) are 'offscfeen drawing' and 'alpha multipass'. you should test with those two items if nothing else. In my experience, opengl usually works ok if you have frameskip on. it isn't as smooth, but playable, and SOO much better graphics. but ... that's if your hardware can handle it.

Re: Legend of Dragoon

Posted: Thu Sep 13, 2012 8:06 pm
by Kethus
Tried several combinations of Hardware acceleration, Screenfiltering and Force mono core, then did the same thing and got the same results. Until a week or so ago I thought I should always force mono core since my phone has a single core, then I removed it and the screen became blurry and the game faster. Also when Force mono core was enabled the picture was freezing every time I went to the menu and disabling it fixed that. But now after enabling and disabling these three options there is no change at all. The game is always blurry and the fps are exactly the same. I picked a normal moment followed by a flashy attack and the fps always drop at 30fps (+ or -3), no matter the three settings mentioned here. And the enemy always strikes back - I couldn't replicate the original problem. I don't think there were any updates since I posted about it, I always get notified when there is an update.
Took a look at your post and it was helpful. Turned out there was an OpenGL setting for Legend of Dragoon. Enabling only Alpha Multipass took care of the menus, don't know what the blue glitch is, I didn't see it. The logo appears like this only if 32Bits rendering is enabled, without that it appears like this: and that's not the playstation logo, I have fast boot enabled, so that's just the first text that appears in the game.
OpenGL also fixes the semi-transparent vectors appearing black. making it easier to see when to press the X button and the rain not look like blood. Video options don't seem to have any effect on that, it's always transparent in OpenGL and always black in Software GPU.

Re: Legend of Dragoon

Posted: Fri Sep 14, 2012 12:11 am
by bluezeak
the main thing I wanted you to try was to turn off the filtering (the option that makes the screen 'fuzzy'). I hoped if we could get that turned off, it may assist with your game.

See the following link. It descripbes what we discovered about the new version of fpse and how it forces the filtering to be always on, and how it can be turned off. Please confirm that you did things as they described, and if it turns off the screen filtering - are you able to get filtering off?

from your post, it sounds like you were not able to get the game to work correctly no matter what option you checked.

You said disabling force monocore made the screen freezing STOP? that's very backwards - for most people turning it on makes the game more stable. very weird.

do you have the same problems with the game in opengl, or were you able to get past the boss / fights? what is the performance like in opengl?

Re: Legend of Dragoon

Posted: Fri Sep 14, 2012 9:43 am
by Kethus
This time I quit and started FPse again after every change in the settings I made. With all three options disabled I get the razor-sharp pixels back and fps counter flickering. With only Screenfiltering I get blurry graphics and fps counter flickering. With only Hardware acceleration I get blurry graphics, no fps counter flickering. Only Force mono core has the same effect as only Hardare acceleration, but with blocky graphics and the picture freezes when I press the menu button, but is fixed when I flip the screen. Enabling Hardware acceleration with Force mono core removes the problem completely. Enabling Screenfiltering after this makes the graphics blurry and the picture freezing returns. Force mono core with only Screenfiltering have the same effect.
Now about the battles. I managed to test the bug in a controlled manner with save states and it appears to be a game bug, not an emulator: it triggers after 10 of the 11 spells I tested and it must be the boss' turn after the spell was casted. It also happens in OpenGL. But it doesn't trigger when using the same spells against the same boss on the PC.
The performance in OpenGL varies wildly from fullspeed in idle areas to 10fps when I start the game and the main menu fades in and average of 30fps during battles. That's what the fps counter shows, it feels much lower. It can't be played with fps skipping, I'd prefer the slowmo.

Re: Legend of Dragoon

Posted: Fri Sep 14, 2012 10:27 am
by bluezeak
that was FANTASTIC information. thank you.

Please see this thread:

Just to be clear - if you do the 'fix' you said above, does this fix the issue where pressing the menu button freezes the game, and rotating the screen unfreezes it? If not - please post in that forum that I am mistaken.

Also, to clarify, are you having two problems? [list[
1) freeze ups with menu button, rotating screen fixes it
2) problems with game after casting spell / boss fight?
or - is the issue the same, and you can fix the freeze up with boss fight by rotating the screen?

Re: Legend of Dragoon

Posted: Fri Sep 14, 2012 10:46 am
by Kethus
I can fix only the screen freezing. The bugs with the boss battle remain. The two are unrelated. The boss battle bug doesn't make the screen freeze. Everyone is moving as normal, they just stand in their idle animations waiting for the boss to make a move. But he doesn't. It happens on FPse, doesn't happen on ePSXe on the PC. I can switch to the PC for boss battles, but that's another story that I've mentioned here.