Page 12 of 23

Re: Final Fantasy VII

Posted: Mon Jul 23, 2012 2:19 am
by Ivegottheskill
bluezeak wrote:I don't know if you can convert you save states. I suspect not. Google it. You can definitely use save game files (memory card files) from fpse in epsxe. I haven't played ff VII far enough to give advice. Have you searched through the forum here, or outside of fpse for fixes for simialar issues in other emus? If you do find something let us know!

I think the main workaround is to get your game saved to a memory card, copy the memory card to the computer, play through it on the computer, save, then copy the memory card back. To copy your memory card go to the misc menu, and choose 'backup'. It will be saved to /sdcard/fpsebackup. plug your phone into your computer and copy the memory card files over. when done, copy them back wherever you want. Then in fpse go to misc, memory card, and brose to where you saved them.

Thanks for your reply.

I tried everything I could think of, without any luck, including:

- backed up the app and reinstalled it and then tried the savestates by copying them over individually (via root access)
- tried many online utilities to try and read the savestates on PC
- tried to delete the memory card files in case they were somehow corrupt

Unfortunately nothing worked. I believe that FPSE did not load properly on an occassion when I played and it caused my save states to become corrupted. I noticed that I could play the game, but FMV videos would not play properly (e.g. grey screen when climing the lift in Junon harbour or Gold Saucer etc). One example of a bad load I've seen is where FPSE asks to select an ISO. I select it, and then the same menu pops up again. I select again, but I notice that the "HLE enabled" notice pops up and there are no save states listed. Quitting the app and reloading often fixes this. But FPSE still has some bugs in that area

My 'solution' was to load my game from my most recent memory card save and play through the 4-5 hrs of game time again. I'm now going to try and exclusively save via in-game save points if possible to reduce chances of this glitch occurring again.

@digitsix: I agree, the sound in FF7 is not 100% perfect. This is quite noticable when scrolling through a list of items or materia - the sound is weird and not uniform. It's not bad sound, but the notes are definitiely clipped in places.

@Biofilm: I had the same problem (see my posts). I'm sorry to say, but it sounds like your save states might have been corrupted by FPSE. I suspect that this happens when the disc ISO is not loaded correctly by the app, or is not being accessed correctly by the app. As mentioned above, the only solution I could come up with was to load my game from my most recent Memory Card save in the game and play through the 4-5 hrs of game time which I had played without saving to the Memory Card in-game.

I strongly recommend using the in-game save points and Memory Cards instead of save states if possible to avoid this problem.

Re: Final Fantasy VII

Posted: Tue Jul 24, 2012 8:07 am
by Imnothimm
So i spent 4 hours trying to get the game to run with open GL settings through fpse... No dice.
So I switched back to software gpu
I downloaded Chainfire 3d pro and all the plugins.
Configured FPSE in the per app options only thing i did was enable the Qualcom plugin. I launched FPSE from inside chainfire and voila! I now have a fully working FFVII with cutscenes running at 60fps(minor slow down with transition to battles) with frame limiter on and close to 500fps with it off(300fps in battles).
Also something to note: I had massive slow down with Tifa and her limit (6fps) It only lasted a couple of battles though and seems to have fixed itself.
Hope this helps someone...

Re: Final Fantasy VII

Posted: Tue Jul 24, 2012 6:43 pm
by Prfndhatrdofman
bluezeak wrote:I'm sorry for quiting such a long post but the settings they're talking about are important for my OpenGL documentation project.

Please see my signature link!! Be sure to look at the goole docs spreadsheet. Some of the special fixes ate for ff7.

I'm going to test ff7 in the near future and post my findings. In my experience 32bits can break things and very rarely does it make a difference in the gfx, so I usually have it off. I've not seen antialiasing do much but maybe my system can't handle it. I'd rather have the game run faster without it usually. The lines around boxes is the alpha multi pass, nd I'm pretty sure ff7 needs it. Some of the special fixes are for the battle swirl. (frame buffer access, upload detection)

I've tried frame buffer access and upload detection, and the battle swirl still fails. There is something bigger going on with the opengl plug in for ff7. something the FPSE version is missing.

Re: Final Fantasy VII

Posted: Wed Aug 01, 2012 4:29 pm
by ManuBBXX
Hello all.
By advance, sorry for my bad english.. Here is my problem :

On my Samsung Galaxy SII, i want to run FF7 in Opengl mode( peops plugin, download auto from fpse in misc switch mode ).
I'm able to pass the first cinematic, but when Clad leaves the train, just at the first battle vs the 2 red soldiers, the sound begin corrupted at the battle swirm, and fpse crashes 10 seconds later, and restart. I tried few graphic parameters in the opengl config video, but no way..

Someone here knows running ff7 in opengl mode ? Cause the difference between normal mode, I think it's great trying it in opengl..

Re: Final Fantasy VII

Posted: Wed Aug 01, 2012 6:08 pm
by ManuBBXX
Hi guys I'm here to report some feedback !

I have the Galaxy s2 and i have to do the mali400 trick to use Opengl plugin. It works pefectly for Resident evil but with FF7 when the battle start, the sound is going creepy and FPSE crash and goes back to the main menu to load an ISO.
I used neiljwd and rand4ll settings and I have the last version of FPSE.

If anyone can help me thank you

I encounter exactly the same problem, crash at the first battle wirl, but the game run normal before it. Any ideas ? I tried all the settings to this great topic but, anyway, let me wrong.

Re: Final Fantasy VII

Posted: Sat Aug 04, 2012 9:18 pm
by trundley
Im running on a Nexus 7 and I'm stuck. I have a .cue and .bin file. I've got the SCPH1001 BIOS file and selected it to load and when i choose the ISO to load i get the old playstation logo with the bit of sound and then FPse crashes out.

Im running these from the internal storage, not an SD card, if that makes a difference.

Re: Final Fantasy VII

Posted: Mon Aug 06, 2012 11:17 pm
by Dust and Jam
I may be a techno-idiot but when I first downloaded fpse I was having real trouble getting FF7 to run.

I’m using a HTC Wildfire S with Android 2.3.5. I found that the game would load, the intro sequence would play, the game looked fine when running around midgar and didn’t even slow down during battles. It was all amazing.

Unfortunately, it would crash at random, and I could not even make it to the first save point without it crashing for no reason.

Luckily for me I was shown a way to solve this, and I’m posting here for any other techno-idiots who are having the same problem.

All you have to do is leave the fpse emulator and go into phone settings. From there go to ‘Power’, and at the bottom there is an option call ‘Fast Boot’ with the following warning – ‘Turn off to use some Market apps’.

Since turning this option off fpse and FF7 have been working almost perfectly. It has crashed one or two times since then but by saving regularly this isn’t too much of a problem.

I hope this advice helps someone, and if anyone has any advice to stop it crashing completely, that would be fantastic!

Awesome app, thanks very much to the programmers!!!

Re: Final Fantasy VII

Posted: Mon Aug 13, 2012 4:01 am
by KuroNeko
Hi all, I'm a new user. :)

Lemme start by thanking you for the hard work you've put on this emulator.. an extremely valid application, with lot of settings too (for which there is no explanation given but a very old ''help'' guide, though, might be a good idea to include it in the next update, if there will ever be one).

Now, let's get to the problem at hand: Final Fantasy VII is not working anymore.. I mean, it was working until I got to Sector 5, saved twice on two different saves (in case something happens to one, I always do like this) and quitted.. then I restart the emulator, load the save and get playing again.. but whether I go back to the previous area, continue to the next, select a category in the menu or join a battle, the game gets stuck. It doesn't crash, it simply won't load the new zone/area/screen. Black screen. W/ sound keep running just fine in background (weird...).
And if I load one of those two saves again the same problem happens, again and again.

BUT, if I load a different save (very old actually) the game goes on just fine, which is why I assume there's a problem with that save or that area in particular or my settings or my game configuration (I don't know, maybe there's a max n. of objects you can carry until the game just stop working, lol) up that point..
I don't think it is a problem of the ISO as I already completed the game once on Pc.. but I wouldn't exclude the chance it is not working fine on this emulator either.

I know I might start a new game, save every new area on a different slot and keep playing until the end but I'd like to use this save as I already played quite a few hours trying to level up.
Is there a way to do it ? I mean, maybe I can use another emulator and go on for a bit and then get back to FPSE.. If I were sure it was possible/it would work.

Hope you can help me as I didn't find any kind of solution on the web and this looked like the best place to ask. :)

PS: My sound is working ALMOST fine and KINDA fluid, but I can hear a little ''creep creep'' in the background if I listen closely.
Settings are "Force Mono Core", "Fast Boot" and "Frame Limiter" (no audio plug-in activated) on FPSE 0.11.29, Xperia Pro, about 50/60 fps avg, .ini files untouched.

Re: Final Fantasy VII

Posted: Wed Aug 15, 2012 5:51 pm
by Zujuju
Hey guys, let me start by saying that FPSE is an amazing program that has allowed me to relive some meaningful moments in my child-hood. Thank you to the developers and all those whose push to make this program even better. With that being said, I am having a unique problem with FF7. I have been playing final fantasy vii on fpse and I use a HP Touchpad. I beat disc one and now it is asking me to change discs to disc 2. Everytime i "eject" the disc to load disc 2, the app freaks out and force closes. Is there a proper way to change discs that i am not seeing? I tried saving the game when it asks me to and opening disc 2 to load it but disc 2 dosnt acknowledge my saved data on the memory card.

Any help would be appreciated guys. Thanks a lot!

Re: Final Fantasy VII

Posted: Thu Aug 16, 2012 1:29 am
by KuroNeko
Guess no Devs are checking this thread anymore, what a shame.

And that is why I'm gonna play FFVII on PSP, see you.

PS: I remember something about that problem, you had to load a previous save and change disc and load the new one or something like that, just play with the saves and you'll soon get to a solution.