Final Fantasy VII

If you have a problem with a particular game, post it in here.
TheHand
Fresh Fish
Posts: 1
Joined: Sun Mar 08, 2015 9:29 pm
Primary Device: SGH-I747
Operating System: Android
ROM: Cyanogenmod 10.2.1-d2att

Re: Final Fantasy VII

Postby TheHand » Mon Mar 09, 2015 12:04 am

I have an SGH-I747 and have updated it with Cyanogenmod to the last stable version supported, 10.2.1 (which is based on Android v4.3). I am using SCPH7502 BIOS, and have "OpenGL High Definition" for the video mode, and found the settings "Alpha Multipass" and "FF7 cursor fix" to be the only necessary hacks for my device that I can tell (but I can only tell by appearance of the game). Final Fantasy 7 runs at a near-constant 60fps when I use Boost Mode at "Normal" setting, but the game does still have some graphical glitches that I would like to see fixed. The only two I have seen so far is the battle swirl graphical effect at the beginning of a random encounter, and the explosion effect right after fighting Air Buster. Here is a video showing the two glitches: https://www.youtube.com/watch?v=gYb7QiXsheE .
Is there some way for me to run a Debug version or send log files or something to help the developers to understand why this is happening? I may have the wrong settings, I have tried several recommended settings that people have posted online for use with this emulator, and have messed with the settings for several hours, but I will try whatever settings you want me to.

Joeyb123
Fresh Fish
Posts: 4
Joined: Fri Jun 19, 2015 4:07 pm
Primary Device: Samsung S5
Operating System: Andriod
ROM: stock

Re: Final Fantasy VII

Postby Joeyb123 » Fri Jun 19, 2015 5:04 pm

Hey folks bit of a bump! Just got this and downloaded OpenGL

Open GL makes it much better from sharpness point of view, however two minor issues...

During Cutscenes/FMV's I seem to have thin black lines down the screen about a cm apart, they're very thin and so you can still see the FMV, but it's noticeable.

Also during battles, I notice at the end mainly during the victory animation the texture of the floor seems to become white triangles, they sort of encroach towards you from where the enemy was.

The former FMV issue is the bigger one for me if there's any solution.

Settings wise I have...

Framelimiter: on

Frameskip: off

Adjust framebuffer: on

Special upload detection: on

Offscreen: on

Advanced blending: on

Alpha Multipass: on

Mask bit: on

32 bit: on

AA: on

Texture filtering: on

Frame texture: on

Busy fix: on

Disable coord check: on

Remove blue glitch: on

FF7 cursor: on

Joeyb123
Fresh Fish
Posts: 4
Joined: Fri Jun 19, 2015 4:07 pm
Primary Device: Samsung S5
Operating System: Andriod
ROM: stock

Re: Final Fantasy VII

Postby Joeyb123 » Sun Jun 21, 2015 8:00 pm

Hey folks, so I fixed the triangle issue by turning off advanced blending.

Still the lines down is still there. I have noticed it isn't in the FMV scenes like say the start with Aeris(th), it's cutscenes which use the in-game graphics, so for example the train pulling into the station at the start where you can see the guards, or Cloud looking up at the reactor just when you name him/Barrett.

Bearpowers
Junior Member
Posts: 6
Joined: Tue Aug 07, 2012 9:21 pm
Primary Device: EVO 3D
Operating System: Android 4.0.3
ROM: Stock

Re: Final Fantasy VII

Postby Bearpowers » Fri Jul 03, 2015 10:46 pm

This thread is slow so I'll just have to pray for a reply soonish.

I'm trying to play FF7 but as soon as I get off the train in the beginning and the 2 soldiers rush towards me it freezes up.

I really like all the bells and whistles of OpenGL so I'd rather not switch to software.

I also get a black hand as my cursor.

This is on a T-Mobile S5, latest stock rom

Zain
Fresh Fish
Posts: 1
Joined: Wed Jul 08, 2015 7:38 am
Primary Device: Android

Re: Final Fantasy VII

Postby Zain » Wed Jul 08, 2015 8:18 am

Hey there my english is not the best so please excues me for any mistakes

my problem : Im on disc2 after destroing the barrier in the north...After flying there to look after sephirot starts a sequence with scarlet reeve and heidger...they are talking about that the kannon must rest bevor shoot again and their trying to call someone...then there musst come a sequence with hojo on the top of the cannon...but it dosent after the calling im staying with cloud on top of the cannon...

Pls help

kokotas
Junior Member
Posts: 10
Joined: Sun Feb 13, 2011 8:03 pm
Primary Device: hd2

Re: Final Fantasy VII

Postby kokotas » Tue Nov 08, 2016 12:35 pm

They vertical lines issue is still there after all this time
exactly as described in the previous post...


Return to “Game-Specific Help”

Who is online

Users browsing this forum: Bing [Bot] and 2 guests